AlmaLinux dnf update error: GPG check failed

28 Jan

Masalah pemeriksaan GPG gagal karena kunci gpg dari versi os sudah tidak valid, biasanya terjadi karena admin malas update os. Problem dnf update karena gpg check failed muncul error seperti dibawah ini:

Importing GPG key 0xC21AD6EA:
Userid : “AlmaLinux [email protected]
Fingerprint: E53C F5EF 91CE B0AD 1812 ECB8 51D6 647E C21A D6EA
From : /etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Key imported successfully
Import of key(s) didn’t help, wrong key(s)?
Public key for kernel-4.18.0-513.11.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-4.18.0-513.11.1.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-core-4.18.0-513.11.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-core-4.18.0-513.11.1.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-modules-4.18.0-513.11.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-modules-4.18.0-513.11.1.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-1:1.40.16-13.el8_9.alma.1.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-libnm-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-libnm-1:1.40.16-13.el8_9.alma.1.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-team-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-team-1:1.40.16-13.el8_9.alma.1.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-tui-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-tui-1:1.40.16-13.el8_9.alma.1.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-headers-4.18.0-513.11.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-headers-4.18.0-513.11.1.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-tools-4.18.0-513.11.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-tools-4.18.0-513.11.1.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-tools-libs-4.18.0-513.11.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-tools-libs-4.18.0-513.11.1.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for platform-python-3.6.8-56.el8_9.3.alma.1.x86_64.rpm is not installed. Failing package is: platform-python-3.6.8-56.el8_9.3.alma.1.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-libs-3.6.8-56.el8_9.3.alma.1.x86_64.rpm is not installed. Failing package is: python3-libs-3.6.8-56.el8_9.3.alma.1.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-perf-4.18.0-513.11.1.el8_9.x86_64.rpm is not installed. Failing package is: python3-perf-4.18.0-513.11.1.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-urllib3-1.24.2-5.el8_9.2.noarch.rpm is not installed. Failing package is: python3-urllib3-1.24.2-5.el8_9.2.noarch
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sqlite-3.26.0-19.el8_9.x86_64.rpm is not installed. Failing package is: sqlite-3.26.0-19.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sqlite-devel-3.26.0-19.el8_9.x86_64.rpm is not installed. Failing package is: sqlite-devel-3.26.0-19.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sqlite-libs-3.26.0-19.el8_9.x86_64.rpm is not installed. Failing package is: sqlite-libs-3.26.0-19.el8_9.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for platform-python-devel-3.6.8-56.el8_9.3.alma.1.x86_64.rpm is not installed. Failing package is: platform-python-devel-3.6.8-56.el8_9.3.alma.1.x86_64
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Error: GPG check FAILED

Solusi dari masalah dnf update gpg check failed adalah melalui memperbarui gpg key dengan perintah dibawah ini:

# rpm --import https://repo.almalinux.org/almalinux/RPM-GPG-KEY-AlmaLinux

2 Replies to “AlmaLinux dnf update error: GPG check failed

Leave a Reply

Your email address will not be published. Required fields are marked *

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.